Purchase Your Hardware

Patient Tablet users:

Patient Tablets require a WiFi-connected Android device (running Android 5.0 or higher). More details and our recommendations are included in the "Buy Your Tablet(s)" step of the Tablet Set-Up Guide.

Check-In Kiosk users:

Check-In Kiosk stands and peripheral hardware can be ordered directly from CognisantMD from the Check-In Kiosk product page. You will also need to independently purchase a compatible tablet for your kiosk (i.e. the Samsung Galaxy Tab E (9.6")).

Have more questions? Submit a request